DAG Network Subnets Misconfigured Error in Exchange 2016

Came across the below error while configuring Database Availability Group in Exchange 2016.


which is clearly shows that there is some issues with Network Adapters configuration of MAPI and Replication networks.

After going though the deep investigation found the issue and got it resolved after doing the few changes in the Replication Network adapters of both the DAG Members.

Open the Properties of the Replication network card. Heartbeat is replication network card name in my test lab

Select IPV4 and go to Properties

2go to Advanced


under DNS, Uncheck Register this Connection’s Addresses in DNS


in Exchange Management Shell, run the below command

Set-DatabaseAvailabilityGroup -Identity DAG -ManualNetworkConfiguration $True


Now check the DAG Networks by running the Command

Get-DatabaseAvailabilityGroupNetwork -Identity DAG |fl


Basically Networks cards in the DAG members should be configured with below configurations.

  1. The MAPI, or client-facing network interface should be configured with
    • a default gateway
    • at least one DNS server
    • “Register this connection’s addresses in DNS” enabled
  2. The replication network interfaces, if there are any, should be configured with:
    • no default gateway
    • no DNS servers
    • “Register this connection’s address in DNS” disabled
    • static routes if the network will span multiple IP subnets

Leave a Reply

Your email address will not be published. Required fields are marked *