Installing ExchangeOnlineManagement Version 2.0.6-Preview6 Preview

Microsoft has announced ExchangeonlineManagement Powershell 2.0.6 Preview v2. which is ideally super excited for Exchange Folks to have REST API Connections and Avoid Basic Authentications

Why do we require REST API Connections to connect to Exchange Online?

  1. Microsoft Blocked Basic Authentications to Exchange Online and other services. for more details
  2. Companies block WinRM basic Connections from the Machines using GPOs or different options as it is vulnerable.
  3. REST API Connections are stable and provide new enhanced CMDLETs

For more details about the 2.0.6-Preview6 version- Please read Microsoft Article

Let us see how we can configure the new version

Step 1: Install Latest version of PowerShellGet

Open Powershell in elevated rights and run the following cmdlet

Install-Module PowerShellGet -Force -AllowClobber

Step 2: Run the following Cmdlet
Install-Module -Name ExchangeOnlineManagement -RequiredVersion 2.0.6-Preview6 -AllowPrerelease

Now, ExchangeOnlineManagement has been installed

Step 3: Run Import-Module -Name ExchangeOnlineManagement

Step 4: Run Get-Module -Name ExchangeOnlineManagement

Leave a Reply

Your email address will not be published.